Onsite installation - software requirements

This topic contains the following software requirements:

Master, relays, and clients

The BMC Client Management master requires the Oracle Java Runtime Environment (JRE) version 1.8 or later (provided with the installation program for Windows installations).

Operating Systems6Master server 1,2,3,5Relays1,2,3,4,5Clients 1,2,3,4,5
Windows
Windows Server 2008 SP2 (32/64 bit)(tick)(tick)(tick)
Windows Server 2008 R2 SP1(tick)(tick)(tick)
Windows Server 2012(tick)(tick)(tick)
Windows Server 2012 R2(tick)(tick)(tick)
Windows Server 2016(tick)(tick)(tick)
Windows XP SP2 (64 bit)(error)(warning)(tick)
Windows XP SP3 (32 bit)(error)(warning)(tick)
Windows XP Embedded SP3 (32/64 bit)(error)(warning)(tick)
Windows Vista with SP1 (32/64 bit)(error)(warning)(tick)
Windows 7 (32/64 bit)(warning)(warning)(tick)
Windows 7 Embedded (32/64 bit)(error)(warning)(tick)
Windows 8 (32/64 bit)(warning)(warning)(tick)
Windows 8.1 (32/64 bit)(warning)(warning)(tick)
Windows 8.1 Embedded (32/64 bit)(error)(warning)(tick)
Windows 10 (32/64 bit)(error)(warning)(tick)
Linux
Red Hat Enterprise 6 and 7(tick)(tick)(tick)
Suse 12(error) (tick)(tick)
Suse 13(tick) (tick)(tick)
CentOS 6 and 7(tick)(tick)(tick)
Debian 8(tick)(tick)(tick)
Ubuntu LTS 14.04(tick)(tick)(tick)
Ubuntu LTS 16.04(tick)(tick)(tick)
Mac
Mac OS X v10.5 (Leopard)(error)(warning)(tick)
Mac OS X v10.6 (Snow Leopard)(error)(warning)(tick)
Mac OS X v10.7 (Lion)(error)(warning)(tick)
Intel Based Mac OS: v10.8 (Mountain Lion)(error)(warning)(tick)
Intel Based Mac OS: v10.9 (Mavericks)(error)(warning)(tick)
Intel Based Mac OS: v10.10 (Yosemite)(error)(warning)(tick)
Intel Based Mac OS: v10.11 (El Capitan)(error)(warning)(tick)
Intel Based, Mac OS: v10.12 (Sierra)(error)(warning)(tick)

Legend:

(tick): Fully supported.

(warning): Supported for evaluation and proof of concept only, not recommended for production environment.

(error): Not supported.

  1. Minimum requirements do not include the total requirements for the server operating system or any other application (that is, MS SQL, MS IIS, antivirus, and so on) installed on the same server.
  2. If several Client Management components (that is, Client Management Master Server, database, or web server application) are installed together on a common server, the minimum requirements for each server component must be combined, and note 1 also applies.
  3. Actual requirements and product functionality might vary based on your system configuration and operating system.
  4. Recommendation: at least 512 Kbps connectivity from audited computer to Client Management relay.
  5. Itanium 64-bit processors are not supported.
  6. Hardware used must support x86_64 architecture (Intel®-based hardware).

BMC Client Management master database server

Platform

Supported versions

Microsoft SQL Server

(Express, Standard and Enterprise editions (Windows masters only)

  • Microsoft SQL Server 2012 (32/64 bit)
  • Microsoft SQL Server 2014 (32/64 bit)
  • Microsoft SQL Server 2016 (32/64 bit)

Oracle RDBMS

  • Oracle 11g: 11.2.0.2 (with 10.2.0.4/5 or 11.2.0.2 client), 11.2.0.3
  • Oracle 12c: 12.1.0.2.0

PostgreSQL (Linux masters only)

  • PostgreSQL 9

For more information, see Database best practices.

BMC recommends you to set the compatibility mode of the database hosted on SQL Server 2016 to SQL Server 2014 to avoid performance issues.

BMC Client Management console

The BMC Client Management console requires the Java Runtime Environment (JRE) version 1.8 and later (version 1.8 update 40 is provided with the installation program).

Supported directory servers

Component

Supported Platforms

Microsoft Active Directory

Microsoft Active Directory Services (ADS) 2008 R2, 2012, 2012 R2, and 2016

Lotus Domino

Lotus Domino 9.0

Novell eDirectory

Novell eDirectory 8.8

LDAP

Supported browsers

The BMC Client Management user interface, specifically, the MyApps application kiosk, requires one of the following browsers:

Browser

Notes

Google Chrome (version 43 and later)

Requires the LocalLink Add-on to be installed if intranet shares are to be advertised in MyApps.

Microsoft Internet Explorer 10 and 11

Microsoft Edge (version 20 and later)

Mozilla Firefox (version 38 and later)

Requires the LocalLink Add-on to be installed if intranet shares are to be advertised in MyApps.

Apple Safari (versions 6 and later)

Does not support direct links to intranet shares in MyApps.

Supported email servers and platforms

Component

Supported Platforms

Email Servers with support for SMTP

  • BMC Client Management requires SMTP for sending email notifications
  • Secure SMTP (SSL)
  • Authenticated SMTP
Was this page helpful? Yes No Submitting... Thank you

Comments