This documentation supports the 9.1 version of Remedy Action Request System.

To view the latest version, select the version from the Product version menu.

Migrating to the current release of BMC Remedy AR System C API

This section summarizes the C API changes from the 7.5 release through the 9.1 release of BMC Remedy AR System.

BMC Remedy AR System 9.1 is backward-compatible, supporting all requests from client applications that use the 7.6, 7.5, 7.1, 7.0, 6.3, 6.0, 5.1, 5.0, 4.x, or 3.2 API libraries. If you continue to link to one of these libraries, you do not need to make any changes to continue running your existing programs against BMC Remedy AR System 9.1 servers.

If you link to the 9.1 API libraries, you must make changes to your existing programs and recompile them. The main program structure and processing, however, need not change.

Some API changes that were made as of release 9.1 might affect your existing API programs compiled with API releases previous to 9.1. Use the following information to understand the changes and additions to the API.

Was this page helpful? Yes No Submitting... Thank you


  1. Vinod Gaidhani

    HI Team,


    Above page refers to version 8.1, is the statement of backward compatibility is still valid for version 9.x as well.

    May 17, 2016 06:37
    1. Prachi Kalyani

      Hello Vinod,

      Thank you for bringing this to our notice. I have updated the topic.



      May 17, 2016 07:02
  2. Eric Winterton

    Hello Team,

    The above page refers to the 9.1 release of the C API and indicates that it is backwards compatible to "7.6, 7.5, 7.1, 7.0, 6.3, 6.0, 5.1, 5.0, 4.x, or 3.2 API libraries". Can you confirm that the 9.1 API is backwards compatible to 8.1 API libraries as well?


    Feb 27, 2018 11:06
  3. Piotr Sadowski

    Hi BMC, this statement that "BMC Remedy AR System 9.1 is backward-compatible, supporting all requests from client applications..." is not true - we received information from Rawle Gibson (Sr. Manager R&D - DSM Engineering), that: "there are instances (and especially with older api’s no longer supported – as in the case of 7.5 api) where there may be anomalous behavior or problems that occur because of the delta between the disparate api versions. In cases such as these the recommendation is to update the client api to at least a supported version and preferably to one that is in alignment with current server. So, yes it is correct that you do not have to update the api program in most cases but when there is a problem and if it is found to be due to the older api then yes, you have to." So documentation should be clarified that 9.1 is not fully compatibility with older versions, and there are some API which are no longer supported. The information on this site misled us and we thought that 9.1 is fully compatibility with previous version 7.5. Thanks, Piotr

    Jun 13, 2018 05:37