This documentation supports the 9.0 version of Remedy Action Request System.

To view the latest version, select the version from the Product version menu.

Server and object navigation differences

The following table explains the server and object navigation differences.

Server and object navigation differences

Function BMC Remedy Developer Studio BMC Remedy Administrator
Group or visually compare different lists of objects There is a single AR System Navigator view that shows all servers. Each distinct object list can be opened once. You can open a separate BMC Remedy Developer Studio using a different workspace and open the same object list with different filtering or other settings. Create a new Server Window.
Display a list of all objects of a type (for example, list of all filters) Double-click the object type in the All Objects subtree in AR System Navigator. Click the object type in the server object tree in Server Window.
Find an object in a list
  1. In the object list, open the Filtering Options or select an object in the list and type the one or more characters to move the selection to the first object that starts with those characters.
  2. Select Search > Search to list all objects that contain the search text.
  1. Select File > Find.
  2. Press F3.
Switch to another window
  • To switch to an editor, hold down CTRL and press F6 until the one that you want is selected.
  • To a select a view, hold down CTRL and press F7 until the one that you want is selected.
Hold down CTRL and press TAB.
View objects associated with a form (View by Form functionality) In AR System Navigator, create a custom View by Form working list. This definition is persistent. Create a new Server Window and configure list of forms. This is not persistent.
View the objects in an application Double-click the application node under Applications in AR System Navigator. Open the Application Window.
View the list of applications and edit their properties
  1. In the AR System Navigator, expand the Applications node under serverName, right-click an application node, and select Edit Application.
  2. Double-click the Application node under All Objects in AR System Navigator to open the Applications object list. Double-click the application in the list to open the Application editor.
  1. Click the Applications node to open the list.
  2. Right-click the selected application and select Properties.
View more columns in an object list
  1. Select Window > Preferences.
  2. In the Preferences dialog box, open BMC Developer Studio and click Object List View.
  3. Select the object list type from the list and configure the columns to display and their order.
Select View > Details.
Create an object (not in an application context)
  1. Right-click the type node in AR System Navigator All Objects subtree.
  2. Select File > New > objectType.
  1. From Server Window, select File > New Server Object or the New Server Object toolbar button. Then, select the object type.
  2. Right-click an object type node in a server tree, and select the command from the pop-up menu.
Create an object (in an application)
  1. Select the application node in the Applications subtree in AR System Navigator (not under All Objects).
  2. Right-click the application and select the object type from the New Object submenu of the context menu.
  1. From the Application Window, select File > New Server Object.
  2. Click the New Server Object toolbar button, and select the object type.
View roles In the AR System Navigator All Objects subtree, double-click Roles. This is a distinct node from Groups. You can only view roles in an object list; you cannot create or edit them. In the Application Window, click Roles/Groups.

Was this page helpful? Yes No Submitting... Thank you

Comments