This documentation applies to the 8.1 version of Remedy Action Request System, which is in "End of Version Support."

To view the latest version, select the version from the Product version menu.

Creating a new report with the BIRT Report Designer

After installing BIRT, you can start creating new reports in the BIRT Report Designer. Perform the workflow in the following procedures to create a new report in the BIRT Report Designer:

To create a new report with the BIRT Report Designer

  1. In the BIRT Report Designer, choose File > New > New Report.
  2. Enter a file name.
    Use the default file location or browse to a different file location.
  3. If you want to use a blank report template, click Finish.
  4. If you want to select a report template, click Next, select a report template, then click Finish.
    The new report appears in the Layout editor pane of the BIRT Report Designer.

    New report in the BIRT Report Designer
    (Click the image to expand it.)

To enable data access for a BIRT report by creating a data source

Before creating new BIRT reports, you must build a BIRT data source to connect a BIRT report to a data source, such as an AR System database. A BIRT data source allows you to access data for a BIRT report.

  1. In the BIRT Report Designer, go to the Data Explorer tab, right-click Data Sources, and select New Data Source.

    Data Explorer pane
    (Click the image to expand it.)
  2. If the Data Explorer tab is not open, choose Window > Show View > Data Explorer.
  3. In the New Data Source dialog box, make sure Create from a data source type in the follow list (default) and BMC Remedy AR System ODA Data Source (default) are selected, and then click Next.

    New Data Source box
    (Click the image to expand it.)

    If BMC Remedy AR System ODA Data Source does not appear as a selection in the New Data Source box, make sure the correct BMC Remedy AR System plug-in files were copied to the BIRT install directory. See To copy BMC Remedy AR System plug-ins for use with BIRT.
  4. In the New BMC Remedy AR System Designtime Data Source Profile dialog box, enter the User Name and Server for the AR System server data source.

    New BMC Remedy AR System Designtime Data Source Profile
    (Click the image to expand it.)

  5. Click Test Connection.
    If the Ping succeeded! message appears, continue to the next step.
    If the Ping failed! error message appears, review the details, correct the data source information, and then test the connection again until you are successful.

  6. Click Finish, and then click OK to close the box.

To define the data available in a report by creating a data set

After creating a new report, you must build a data set to configure the data to extract from data source. The data set defines all data that is available to the report. For example, the data set configuration determines which fields are displayed in the report.

You must create a BIRT data source before you build a data set. For details, see To enable data access for a BIRT report by creating a data source.
  1. In the BIRT Report Designer, click the Data Explorer tab, right-click Data Sets, and select New Data Set.
  2. Configure the New Data Set dialog box:
    1. Enter the Data Set Name, for example, Incident Data Set.
    2. Under the Data Source node, select the data source, and then click Next.
      For example, select a data source previously created for this report.

      New Data Set box
      (Click the image to expand it.)
  3. Configure the Query box:
    1. Select a form from the Form list.

      Query box
      (Click the image to expand it.)
    2. Click Add.
      The Available Fields dialog box displays all fields in the selected form.

      Available fields box
      (Click the image to expand it.)
    3. Select the fields you want to include in the report, and then click OK.
    4. In the Qualification field, enter the criteria to be used for the query, click Verify, and then click Finish.
      Enter the qualification using this format:

      'field' operator "Parameter"


      For example, for the incidents that are not closed, enter:

      'Status' !="Closed"
    5. Click Finish.

      BMC recommends using query for a data set instead of filters. Data set filters are applied to the entire result set, and can impair performance. Use the qualification in the query configuration to filter data.
  4. If you want to change a column label in a report, configure the Output Columns dialog box.
    For example, you can change the Short Description column heading to Description.

    1. Select the output column you want to edit.

    2. Click Edit.
    3. In the Display Name field, change the column label.

    4. Click OK.
      For a description of the parameters that can be configured in the Data Set editor, see the BIRT online help.

To preview and save a new BIRT report

  1. In the Edit Data Set dialog box, preview the data for the new report by clicking Preview Results in the left navigation area, and then click OK.
    The data that fills in the criteria of the data set appears in the right pane of the Edit Data Set box.

    Preview Results in Edit Data Set
    (Click the image to expand it.)
  2. To save the new BIRT report, choose File > Save As, and then enter a meaningful file name in the File Name field.
  3. Click Finish.

This version of the documentation is no longer supported. However, the documentation is available for your convenience. You will not be able to leave comments.

Comments

  1. George Payne

    The link halfway down the page: "To copy BMC AR System plug-ins for use  with BIRT"

    does not go to the advertised page, in fact it comes right back to THIS page.

    May 29, 2014 03:56
  2. David k Hill

    Yup, the issue George reported still goes this page..

    Jun 30, 2016 05:14
    1. Anagha Deshpande

      Hello David,

      I have fixed the link.

       

      Regards,

      Anagha

      Jul 05, 2016 03:50
  3. David k Hill

    Hmm...  I just tried it and it still refers back to the same page.
    This is the link at:  (Marked in Read)
    "

    If BMC Remedy AR System ODA Data Source does not appear as a selection in the New Data Source box, make sure the correct BMC Remedy AR System plug-in files were copied to the BIRT install directory. See To copy BMC Remedy AR System plug-ins for use with BIRT.

    "

     

    Cheers,

     

     

    Jul 05, 2016 07:05
    1. Anagha Deshpande

      Hello David,

      Sorry for the inconvenience.

      I have fixed the link. Please check. 

       

      Regards,

      Anagha

      Jul 06, 2016 10:48
  4. David k Hill

    Yup it's working now.   Thanks!!

    Jul 06, 2016 10:59
  5. David k Hill

    In the section that says:

    'field' operator "Parameter"
    What parameter?  Is this a value or a token that holds the parameter?
    I'm having difficulty integrating a BIRT (Web Report) to take a dynamic query at run time.
    A simple idea is to have a Web Report query for one record then query for related records.

    So far this report creation step appears to only show us how to make a one time report that queries using a hard coded query qualification. 
    It may be very helpful to show how we use the BIRT tool to build the reports that take values at run time. 
    I can download and make copies of existing reports and tweak them a tad and they still work fine.  It's just the process of creating one from scratch that appears to be missing steps.
    Mar 01, 2017 04:05