This documentation supports the 22.1 version of Action Request System.
To view an earlier version, select the version from the Product version menu.

Creating help for applications

You can create help for your users in various areas of the application.

In addition to traditional help as described her,  you create guides that guide users through a form or a series of forms. For more information, see Defining guides and guide actions

Creating help for a form

If you created help for your applications in Developer Studio , users can view that help in a browser window by clicking the Help link in the form's toolbar.

Help in a browser window

If you want to copy information from the AR System  online documentation into your application help, the Offline Documentation file contains an HTML version. 

For instructions on how to download the Offline Documentation file, see  Downloading the installation files Open link  in the  BMC Helix Innovation Suite  Deployment documentation.


You can also create a Help button on the form by using a Form Action field.
To view the HTML version of the AR System  online documentation in a browser, open the index.htm file first.

To create help for a form in a browser by using a Form Action field

  1. Create help for the form and for each field as described below.
  2. Create a Form Help field on the form.
    1. In Developer Studio , open the form, and select Form > Add Form Action Fields. For more information, see Adding form action fields to a form.
    2. Select the Form Help check box, and click OK.
    3. Set field properties for the Help button that appears. See Creating button fields.

To create context-sensitive help text

  1. Open an object in Developer Studio .
  2. Access the help text:
    • For the form help text, select the Definitions tab. Expand the Help Text panel.
    • For a field, select the field, and select the Help Text property.
    • For other objects, open the object, and select the Help Text property.
  3. In the Help Text field, type the text for the users.
  4. Save the object.

Creating field-level help

You can create field-level help for users of your application. For applications that run in Application mode, you can also provide help in the following ways:

  • Using help text that opens from the Help menu in a system-generated dialog box. Use this method if the application does not require extensive help text.
  • Using external help files that open from the Help menu in a supporting program such as a web browser or Adobe Reader. Use this method if the application is complex and requires detailed instructions. You can provide up to five external help files.

To specify help text in a dialog box

Use this procedure to specify help text that users can access by choosing Help > Help on applicationLabel.

  1. In Developer Studio , right-click on the application's name in the AR System Navigator, and select Edit Application.
  2. In the Application tab, expand the Help Text panel.
  3. From the Type drop-down list, select Help Text.
  4. In the field, supply the help text that you want to appear.
  5. Select File > Save.

To specify external help files

You can specify up to five different external help files for an application. Help formats that you can use include .htm.html.doc.pdf.txt.hlp, or .chm files. Your users must be able to access the help file locally on their computers. For example, if your help file is a web page, users must have browsers installed.

  1. In Developer Studio , right-click on the application's name in the AR System Navigator, and select Edit Application.
  2. In the Application tab, expand the Help Text panel.
  3. From the Type drop-down list, select External Help Files.
  4. Click Add.
  5. In the Add External Help File dialog box:
    1. In the Label field, enter a label for the help file.
    2. Click the browse button next to the Help File field and select a file.
    3. Click OK.
      The Label and Help File name are added to the field changes to identify the help file that you have selected.
  6. To test a help file, select it in the list and click Test.
  7. To export a help file from an application, select it in the list and click Save to Disk.
  8. Select File > Save.

Creating help for administrators

For all other server objects (except forms), the help text you create is available only to administrators and subadministrators in Developer Studio . 

The online help for Developer Studio  is packaged in an Eclipse plug-in named com.bmc.arsys.studio.help_ VerNum . (For Remedy Data Import, the plug-in is named com.bmc.arsys.dataimport.help_ VerNum .)

To access help outside of  Developer Studio

  1. In com.bmc.arsys.studio.help_ VerNum , locate the doc.zip file, and unzip the file to a location where you want to store the help files.
    These files do not include a table of contents or an index; they are simply the topic files of the help.
  2. Browse to the folder and launch any of the files to view a topic.
    For Remedy Data Import, follow these steps, but go to the com.bmc.arsys.dataimport.help_ VerNum plug-in.
Was this page helpful? Yes No Submitting... Thank you

Comments