This documentation supports the 21.05 version of Action Request System.
To view an earlier version, select the version from the Product version menu.

Developer Studio interface

Developer Studio  is an Eclipse application, which uses perspectives to organize windows into layouts. In Developer Studio , you work with two perspectives:

  • Developer perspective—Contains tabs and editors to find, create, and modify objects on AR System server s.
  • Editor perspective—Contains only the tabs and editors you need when you are editing an object.

For more information, see Working with perspectives.

The following figure shows the Developer Perspective of Developer Studio .

Developer Studio  and the Developer perspective

The Developer perspective has several parts:

Parts of Developer Studio window

Area

Description

AR System Navigator

Contains a tree of objects for each AR System server that Developer Studio is connected to. Use the items in the tree to create and access objects on the server. See Understanding the AR System Navigator below and Using the Outline tab below.

Object list tab

Contain lists of server objects. To open an object list, double-click a node in the AR System Navigator. Use these lists to find objects to examine or modify. See Viewing objects in an object list.

Editor tab

Contain editors where you can create and modify AR System server objects. For information about modifying objects using the Developer Studio editors, see Working with objects.

Outline tab

Displays a structural outline of the object that you are working on (for most editors). For forms, the Outline tab includes a Zoom Overview button that displays a reduced-size picture of the form. Use the outline to select items in an object. When you select an item in the outline, it is also selected in the editor, and vice versa. When editing a form, use the Zoom Overview to position the form editor on a part of the form. For more information, see Using the Outline tab below.

Properties tab

Displays the properties of the object that you are working on or the properties of a form view or a field in a form. Use this tab to view or change the properties of objects, form views, and fields. See Modifying object properties.

Messages tab

Displays messages about the work that you are doing in an editor. Double-click a message to go to the relevant location in the editor. See Using the Messages tab below.

Progress tab

Shows the progress of long operations, such as an export or import. You can continue working while the operation runs.


Relationships tab

Displays a list of related fields and objects. Right-click an object in an object list, and select Show Relationships to display related fields and objects. Double-click an item in the Relationships tab to edit the object and go to the relevant location in the editor. See Viewing related objects.

Search Results tab

Displays a list of server objects that contain text that you specify. Select Search > Search option to find objects that satisfy your search criteria. You can use the Search Results tab like an object list. See Searching for objects. This tab does not appear until you select the Search menu option.

Analyzer tab

Displays the results of the analysis of one or more objects. Right-click an object in an object list, and select Analyze to analyze objects. Double-click an item in the Analyze tab to edit the object and go to the relevant location in the editor. For more information, see Using Analyzer to find problems in your applications. This tab does not appear until you use the Analyze command.

Perspective bar

Provides a convenient way to switch perspectives. For more information, see Working with perspectives.

Status bar

Displays information about the user logged in and about the object being edited.

If you cannot find a tab, it might be minimized or closed. To open a minimized tab, click the Restore icon ( ) in the window margin. If the tab is closed, use the Window > Show View menu to open it.

Developer Studio  does not support large DPI fonts, which are configured in the Properties dialog box of Windows computers.

In the Developer Studio  user interface, tables often seem to have an empty column on their right side. This illusion occurs when the right column separator for the last data-filled column is visible. The separator enables you to resize the last data-filled column. You can drag the separator until the "empty" column is no longer visible.

Using the AR System Navigator

Use the AR System Navigator (see the following figure) to open object lists and create objects. 

AR System Navigator


The AR System Navigator contains a tree for each connected server. The following server icons signify information about the server: 

Server icons

IconRepresents

Disconnected server

Server, logged in as administrator

Server, logged in as subadministrator

For information about subadministrator access to objects, see Creating a Subadministrator security role

The AR System Navigator gives you access to:

  • Working Lists—Lists of server objects that you use to complete an application development or maintenance task.
    Use the special Reserved Objects working list to access reserved objects. For information about object reservation, see Version control in AR System.
    For more information, see Creating and modifying working lists.
  • Applications—Applications defined on the server.
    See Defining and managing an application.
  • Packing Lists—Functional units that contain an administrator-defined grouping of information. For example, if an application contains ten forms, each form and its related workflow can be organized in its own functional unit, or packing list.
    See Creating and managing packing lists.
  • All Objects—All of the object types that you can define in Developer Studio , for example, forms, active links, and so on.
    Double-click an item (such as Forms) to open an object list. From the object list, you can access the objects of that type.
    See Using the Outline tab below and Working with objects.

    Working lists, applications, and packing lists provide another way to access server objects found under All Objects. Using these containers can reduce the time to find objects that you need to access.

Using the Outline tab

The Outline tab displays a visual overview of the object in an editor. Use it to navigate within the editor. When you select an item in the outline, it is also selected in the editor and vice versa. 

When you are editing a form, the Outline tab contains the following icons:

  • Show Tree Overview ()—Displays all of the fields (ordered by field ID) on the current form view in a tree format. 
  • Show Table Overview ()—Displays all of the fields on the current form view in a table format. You can click on the columns to sort by field ID or by name.
  • Show Fields Not in View ()—Displays fields that are not in the current or selected view including the fields that are not in any view. The fields created from this view are not present in any view. In Best Practice Customization mode, you can create or delete Field Overlay of these fields. You can also see such fields by choosing Form > Add/Remove Fields In View (they are listed in the left pane of the dialog box). See Including and excluding fields from form views.
  • Show Zoom Overview ()—Displays a small picture of the form view with a gray box that you can move to focus the editor on a specific area of the form.

Outline tab with Show Tree Overview displayed 


Outline tab with Show Zoom Overview displayed 

You can view the list of all fields contained in all views of form. If you have created multiple views for a form, you can view a list of all fields contained in all forms. The Outline view also lists the fields that are not in view.

To view all fields in the Outline view

  1. Open Developer Studio  in the Best Practice Customization mode.
  2. Open the form from the Object List.
  3. Select the Definitions tab.
    The Outline view lists the fields in all views of the selected form.

Using the Messages tab

When an editor is active, the Messages tab lists any warnings about the object that you are editing. They often note fields that must be completed before you can save the object. 

The tab also shows a count of all messages. If you minimize the Messages tab, the minimized icon shows the highest severity, and the counts are shown on a tool tip.

To fix a problem described in a warning

  1. Double-click the message in the Messages tab.
    If the message is linked, the insertion point moves to the item in the object editor that you must change.
  2. Fix the problem reported in the message.

    When you try to save an object and the AR System server returns an error, that error is listed in the Messages tab, but it is not linked to the object in the editor.

Was this page helpful? Yes No Submitting... Thank you

Comments