This documentation supports the 19.11 version of Remedy Action Request System, which is available only to BMC Helix subscribers (SaaS).
To view an earlier version, select the version from the Product version menu.

Creating a new web report with the BIRT Report Designer

After installing BIRT, you can start creating new reports in the BIRT Report Designer. Perform the workflow in the following procedures to create a new report in the BIRT Report Designer:

To create a new report with the BIRT Report Designer

  1. In the BIRT Report Designer, choose File > New > New Report.
  2. Enter a file name.
    Use the default file location or browse to a different file location.
  3. If you want to use a blank report template, click Finish.
  4. If you want to select a report template, click Next, select a report template, then click Finish.
    The new report appears in the Layout editor pane of the BIRT Report Designer.

To enable data access for a BIRT report by creating a data source

Before creating new BIRT reports, you must build a BIRT data source to connect a BIRT report to a data source, such as an AR System database. A BIRT data source allows you to access data for a BIRT report.

  1. In the BIRT Report Designer, go to the Data Explorer tab, right-click Data Sources, and select New Data Source.

  2. If the Data Explorer tab is not open, choose Window > Show View > Data Explorer.
  3. In the New Data Source dialog box, make sure Create from a data source type in the follow list (default) and BMC Remedy AR System ODA Data Source (default) are selected, and then click Next.

    Note

    If BMC Remedy AR System ODA Data Source does not appear as a selection in the New Data Source box, make sure the correct BMC Remedy AR System plug-in files were copied to the BIRT install directory.

  4. In the New BMC Remedy AR System Designtime Data Source Profile dialog box, enter the User Name and Server for the AR System server data source.

  5. Click Test Connection.
    If the Ping succeeded! message appears, continue to the next step.
    If the Ping failed! error message appears, review the details, correct the data source information, and then test the connection again until you are successful.

  6. Click Finish, and then click OK to close the box.

To define the data available in a report by creating a data set

After creating a new report, you must build a data set to configure the data to extract from data source. The data set defines all data that is available to the report. For example, the data set configuration determines which fields are displayed in the report.

Important

You must create a BIRT data source before you build a data set.

  1. In the BIRT Report Designer, click the Data Explorer tab, right-click Data Sets, and select New Data Set.
  2. Configure the New Data Set dialog box:
    1. Enter the Data Set Name, for example, Incident Data Set.
    2. Under the Data Source node, select the data source, and then click Next.
      For example, select a data source previously created for this report.

  3. Configure the Query box:
    1. Select a form from the Form list.

    2. Click Add.
      The Available Fields dialog box displays all fields in the selected form.
    3. Select the fields you want to include in the report, and then click OK.
    4. In the Qualification field, enter the criteria to be used for the query, click Verify, and then click Finish.
      Enter the qualification using this format:

      'field' operator "Parameter"

      For example, for the incidents that are not closed, enter:

      'Status' !="Closed"
    5. Click Finish.

      Best Practice

      We recommend using query for a data set instead of filters. Data set filters are applied to the entire result set, and can impair performance. Use the qualification in the query configuration to filter data.

  4. If you want to change a column label in a report, configure the Output Columns dialog box.
    For example, you can change the Short Description column heading to Description.

    1. Select the output column you want to edit.

    2. Click Edit.
    3. In the Display Name field, change the column label.

    4. Click OK.
      For a description of the parameters that can be configured in the Data Set editor, see the BIRT online help.

To preview and save a new BIRT report

  1. In the Edit Data Set dialog box, preview the data for the new report by clicking Preview Results in the left navigation area, and then click OK.
    The data that fills in the criteria of the data set appears in the right pane of the Edit Data Set box.
  2. To save the new BIRT report, choose File > Save As, and then enter a meaningful file name in the File Name field.
  3. Click Finish.

Where to go from here

Creating and modifying web reports by using BIRT editor

Was this page helpful? Yes No Submitting... Thank you

Comments