This documentation supports the 18.05 version of Remedy Action Request System.

To view the latest version, select the version from the Product version menu.

Specifying Help properties for an Application mode

You can create field-level help for users of your application, as explained in Providing help text. For applications that run in Application mode, you can also provide help in the following ways:

  • Using help text that opens from the Help menu in a system-generated dialog box. Use this method if the application does not require extensive help text.
  • Using external help files that open from the Help menu in a supporting program such as a web browser or Adobe Reader. Use this method if the application is complex and requires detailed instructions. You can provide up to five external help files.

Specifying help text in a dialog box

Use the following procedure to specify help text that users can access by choosing Help > Help on applicationLabel.

To specify help text in a dialog box

  1. In BMC Remedy Developer Studio, right-click on the application's name in the AR System Navigator, and select Edit Application.
  2. In the Application tab, expand the Help Text panel.
  3. From the Type drop-down list, select Help Text.
  4. In the field, supply the help text that you want to appear.
  5. Select File > Save.

Specifying external help files

You can specify up to five different external help files for an application. Help formats that you can use include .htm, .html, .doc, .pdf, .txt, .hlp, or .chm files. Your users must be able to access the help file locally on their computers. For example, if your help file is a web page, users must have browsers installed.

To specify external help files

  1. In BMC Remedy Developer Studio, right-click on the application's name in the AR System Navigator, and select Edit Application.
  2. In the Application tab, expand the Help Text panel.
  3. From the Type drop-down list, select External Help Files.
  4. Click Add.
  5. In the Add External Help File dialog box:
    1. In the Label field, enter a label for the help file.
    2. Click the browse button next to the Help File field and select a file.
    3. Click OK.
      The Label and Help File name are added to the field changes to identify the help file that you have selected.
  6. To test a help file, select it in the list and click Test.
  7. To export a help file from an application, select it in the list and click Save to Disk.
  8. Select File > Save.
Was this page helpful? Yes No Submitting... Thank you

Comments