This documentation supports the 18.05 version of Remedy Action Request System.

To view the latest version, select the version from the Product version menu.

BMC Developer Studio frequently asked questions

This section includes questions that you might have about BMC Remedy Developer Studio and their answers.


Q: How do I log on as a different user or change the server list?


A: Select File > Login to display the Login window.


Q: Why does a single click in AR System Navigator not show the list of objects?


A: Selecting an item in AR System Navigator does not open the object list. You must double-click to open it. This way, you can have multiple object lists open at the same time.


Q: How do I open a missing tab?


A: To open an object list, double-click an item in an AR System Navigator sub-tree. To open another tab, select Window > Show View > viewName.


Q: Can I run multiple instances of BMC Remedy Developer Studio?


A: Yes, but you must use different workspaces. When you start BMC Remedy Developer Studio, you are prompted for a new workspace if the references workspace is already in use. You can also switch workspaces from within BMC Remedy Developer Studio using the File > Switch Workspace command.


Q: How do I display two editors side by side?


A: Drag the Editor tab to the edge of the editor window. Drag it back on or next to the other tabs to stack the editor again.



Q: When editing a cell in a mapping table in an Open Window, Push Fields, or Set Fields action, why must I click elsewhere in the table before the data is accepted and the cell is closed?


A: You can usually press Enter to close the cell and accept the data. This is how the Eclipse/SWT JFace table works. It is a current limitation in the tool.


Q: How does multi-select in the form editor display and update field properties?


A: When you selected two or more fields in the form editor, the Properties tab displays the properties that apply to all selected fields. If the fields have different values for a property, the value for the primary selection, the first field selected, appears in the Properties tab. If you change a value in the Properties tab, BMC Remedy Developer Studio applies the change to all the selected fields. Because of an Eclipse limitation, BMC Remedy Developer Studio cannot clear or use a colored background to distinguish fields with mixed values.


Q: Where can I use Undo and Redo?


A: The form editor provides Undo and Redo commands. The Undo and Redo commands are only available in the Edit menu when the form editor has the input focus. If you make a change in the Properties tab, you must click the form editor tab before you can undo it.


Q: How can I use special characters in the Filtering Options Name field and the Locate field in Selector dialog boxes?


A: These two fields use regular expressions for matching. Certain characters, among them * and [, have special meaning. To match a single * in a name, enter [*] in the field.


Q: Since it is actually Eclipse, can I use BMC Remedy Developer Studio to do Sun Java or other development?


A: BMC Remedy Developer Studio is a packaged plug-in to the basic Eclipse IDE, but other development plug-ins are not packaged in. BMC has not tested other Eclipse plug-ins installed alongside BMC Remedy Developer Studio, so it is recommend that you not try this for the release.


Q: Where are the Eclipse menus?


A: The Eclipse menus that are not applicable to BMC Remedy Developer Studio are not included.

This section includes questions that you might have about BMC Remedy Developer Studio and their answers.


Q: How do I log on as a different user or change the server list?


A: Select File > Login to display the Login window.


Q: Why does a single click in AR System Navigator not show the list of objects?


A: Selecting an item in AR System Navigator does not open the object list. You must double-click to open it. This way, you can have multiple object lists open at the same time.


Q: How do I open a missing tab?


A: To open an object list, double-click an item in an AR System Navigator sub-tree. To open another tab, select Window > Show View > viewName.


Q: Can I run multiple instances of BMC Remedy Developer Studio?


A: Yes, but you must use different workspaces. When you start BMC Remedy Developer Studio, you are prompted for a new workspace if the references workspace is already in use. You can also switch workspaces from within BMC Remedy Developer Studio using the File > Switch Workspace command.


Q: How do I display two editors side by side?


A: Drag the Editor tab to the edge of the editor window. Drag it back on or next to the other tabs to stack the editor again.



Q: When editing a cell in a mapping table in an Open Window, Push Fields, or Set Fields action, why must I click elsewhere in the table before the data is accepted and the cell is closed?


A: You can usually press Enter to close the cell and accept the data. This is how the Eclipse/SWT JFace table works. It is a current limitation in the tool.


Q: How does multi-select in the form editor display and update field properties?


A: When you selected two or more fields in the form editor, the Properties tab displays the properties that apply to all selected fields. If the fields have different values for a property, the value for the primary selection, the first field selected, appears in the Properties tab. If you change a value in the Properties tab, BMC Remedy Developer Studio applies the change to all the selected fields. Because of an Eclipse limitation, BMC Remedy Developer Studio cannot clear or use a colored background to distinguish fields with mixed values.


Q: Where can I use Undo and Redo?


A: The form editor provides Undo and Redo commands. The Undo and Redo commands are only available in the Edit menu when the form editor has the input focus. If you make a change in the Properties tab, you must click the form editor tab before you can undo it.


Q: How can I use special characters in the Locate field in Selector dialog boxes?


A: This field uses regular expressions for matching. Certain characters, among them * and [, have special meaning. To match a single * in a name, enter [*] in the field.


Q: Since it is actually Eclipse, can I use BMC Remedy Developer Studio to do Oracle Java or other development?


A: BMC Remedy Developer Studio is a packaged plug-in to the basic Eclipse IDE, but other development plug-ins are not packaged in. BMC has not tested other Eclipse plug-ins installed alongside BMC Remedy Developer Studio, therefore, BMC does not recommend to use it with other development.


Q: Where are the other Eclipse menus?


A: The Eclipse menus that are not applicable to BMC Remedy Developer Studio are not included.

Was this page helpful? Yes No Submitting... Thank you

Comments