This documentation supports the 18.05 version of Remedy Action Request System.

To view the latest version, select the version from the Product version menu.

About BMC Remedy Developer Studio

BMC Remedy Developer Studio is an integrated development environment (IDE) for BMC Remedy AR System applications. It provides all the application development functions of the previous BMC Remedy Administrator tool with a modern, powerful, easy-to-use interface. (The AR System Administration Console provides the server administration functions that BMC Remedy Administrator provided before release 7.1.00.)

BMC Remedy Developer Studio is an Eclipse application, which uses perspectives to organize windows into layouts. In BMC Remedy Developer Studio, you work with two perspectives:

  • Developer perspective — Contains tabs and editors to find, create, and modify objects on BMC Remedy AR System servers.
  • Editor perspective — Contains only the tabs and editors you need when you are editing an object.

For more information, see Working with perspectives.

The following figure shows the Developer Perspective of BMC Remedy Developer Studio.

BMC Remedy Developer Studio and the Developer perspective

The Developer perspective has several parts:


Parts of BMC Remedy Developer Studio window

Area

Description

AR System Navigator

Contains a tree of objects for each BMC Remedy AR System server that BMC Remedy Developer Studio is connected to. Use the items in the tree to create and access objects on the server. See Understanding the AR System Navigator and Using the Outline tab.

Object list tab

Contain lists of server objects. To open an object list, double-click a node in the AR System Navigator. Use these lists to find objects to examine or modify. See Using object lists.

Editor tab

Contain editors where you can create and modify BMC Remedy AR System server objects. For information about modifying objects using the BMC Remedy Developer Studio editors, see Working with existing objects.

Outline tab

Displays a structural outline of the object that you are working on (for most editors). For forms, the Outline tab includes a Zoom Overview button that displays a reduced-size picture of the form. Use the outline to select items in an object. When you select an item in the outline, it is also selected in the editor, and vice versa. When editing a form, use the Zoom Overview to position the form editor on a part of the form. For more information, see Using the Outline tab.

Properties tab

Displays the properties of the object that you are working on or the properties of a form view or a field in a form. Use this tab to view or change the properties of objects, form views, and fields. See Modifying object properties.

Messages tab

Displays messages about the work that you are doing in an editor. Double-click a message to go to the relevant location in the editor. See Using the Messages tab.

Progress tab

Shows the progress of long operations, such as an export or import. You can continue working while the operation runs.


Relationships tab

Displays a list of related fields and objects. Right-click an object in an object list, and select Show Relationships to display related fields and objects. Double-click an item in the Relationships tab to edit the object and go to the relevant location in the editor. See Viewing and sorting related objects.

Search Results tab

Displays a list of server objects that contain text that you specify. Select Search > Search option to find objects that satisfy your search criteria. You can use the Search Results tab like an object list. See Using the Search menu option. This tab does not appear until you select the Search menu option.

Analyzer tab

Displays the results of the analysis of one or more objects. Right-click an object in an object list, and select Analyze to analyze objects. Double-click an item in the Analyze tab to edit the object and go to the relevant location in the editor. For more information, see Using Analyzer to find problems in your applications. This tab does not appear until you use the Analyze command.

Perspective bar

Provides a convenient way to switch perspectives. For more information, see Working with perspectives.

Status bar

Displays information about the user logged in and about the object being edited.

If you cannot find a tab, it might be minimized or closed. To open a minimized tab, click the Restore icon ( ) in the window margin. If the tab is closed, use the Window > Show View menu to open it.

Notes

  • BMC Remedy Developer Studio does not support large DPI fonts, which are configured in the Properties dialog box of Windows computers.
  • In the BMC Remedy Developer Studio user interface, tables often seem to have an empty column on their right side. This illusion occurs when the right column separator for the last data-filled column is visible. The separator enables you to resize the last data-filled column. You can drag the separator until the "empty" column is no longer visible.
Was this page helpful? Yes No Submitting... Thank you

Comments