After upgrading Silk Performer and installing or upgrading the TEA Agent, the TEA Agent doesn't run

After upgrading Silk Performer, and then upgrading or installing the TEA Agent on a computer running a Windows Server operating system, the first time the TEA Agent service or process is run, it may fail. The following messages are issued to the agent.log file:

INFO [LOG_COMMON] Discovered Silk runtime installation folder C:\Program Files (x86)\Silk\Silk Performer 18.0\
INFO [LOG_COMMON] Loaded Silk runtime version 18.0.0
ERROR [ADAPTER_MAIN] ServiceMain: TEA Agent detected incompatible silk runtime version. Make sure Silk Performer 18.5.0 is installed and configured correctly. Reboot the system to be sure the configuration is updated correctly. If the problem persists, contact BMC Support.


Cause

The service manager on Windows Server loads the PATH environment variable on startup and does not update it if there is a change in the environment variable. As a result, the TEA Agent attempts to open the Silk Performer runtime module from the older version of Silk Performer.

Resolution

Restart the computer where the TEA Agent is installed. This updates the PATH environment variable used by the system.

Was this page helpful? Yes No Submitting... Thank you

Comments