Access Denied error when running with WebSphere

If an agent does not have sufficient permissions when running on WebSphere, the App Visibility agent log shows Access Denied error entries.

Issue

The App Visibility agent log shows Access Denied error entries when running with WebSphere.

Probable cause

The agent does not have sufficient permissions on the WebSphere server.

Resolution

On the WebSphere server, edit the permissions in the server.policy file. For more information, see the section on granting Java 2 permissions on IBM WebSphere at  Installing an App Visibility agent using the wizard .

Note

If you copy and paste content when you edit the server.policy file, encoding problems can occur, preventing WebSphere from reading and parsing the file. Hidden coding causes a mismatch between the source and the target. To prevent a code mismatch, paste content into a simple text editor and then copy and paste from the text editor.

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