Software requirements

This topic was edited by a BMC Contributor and has not been approved.  More information.

Supported operating systems

Computers or virtual machines that host the TrueSight Capacity Optimization Application Server and ETL Engine Server components must be running one of the following supported platforms:

Note

  • For Application Server, ETL Server, and Gateway Server components, only x86_64 architecture is supported for the operating systems.
  • To install a TrueSight Capacity Optimization component by using the wizard (GUI) on any Linux operating system, ensure that you install the Xvfb package.

Application Server and ETL Server

Operating system

Version

Required libraries

Red Hat Enterprise Linux

6.x

perl-5.10.1, libXtst, open-sans-fonts.noarch
7.x perl-5.16.3, libXtst, liberation-sans-fonts, perl-HTTP-Message (for GWS VIS File Parser ETL)

Oracle Linux

6.x

perl-5.10.1, libXtst
7.x  

Linux CentOS

6.x

perl-5.10.1, libXtst
7.x perl-5.16.3, libXtst

SUSE Linux Enterprise

11.x

perl-5.10.0, perl-libwww-perl
12  

Note

  • If you are installing the Application Server using the User Interface, ensure that an XServer is either installed locally on your workstation or installed on a remote machine to which you can export the display. If you are connecting to the client from a remote workstation by using a XServer server, ensure that the XServer is already running on the client machine.
  • XServer is not required when you are performing silent installation of the Application Server.
  • If you run the Gateway VIS File Parser ETL on the server that runs on RHEL 7 and where the TrueSight Capacity Optimization is installed, install the perl-HTTP-Message package on the server. 

Gateway Server

Operating system

Version Required libraries

Red Hat Enterprise Linux

6.7 to 6.9 ksh, glibc.x86_64, open-sans-fonts.noarch
7.2 to 7.4 ksh, glibc.x86_64, liberation-sans-fonts

SUSE Linux Enterprise Server

11.x ksh,glibc,glibc-32bit
Microsoft Windows Servers 2012*  
2012 R2  
2016  
Microsoft Windows 10  
Linux CentOS 6.7 to 6.9 ksh, glibc.x86_64
7.2 to 7.3 ksh, glibc.x86_64
Oracle Linux 6.7 to 6.9 ksh, glibc.x86_64
7.2 to 7.3 ksh, glibc.x86_64


Note

Server Core installations for Microsoft Windows Server are not supported.

Capacity Agents

Operating System support for Agent-based data collection

The following table lists the Operating Systems on which you can currently install and use Agent:

Note

  • For data collection from a Solaris 11 computer configured as a zone, the Agent must be installed on the global zone. All non-global zone data is accessible from the global zone.
  • For data collection from a 7.1, or 7.2 computer configured as a WPAR, the Agent must be installed on the global WPAR. All non-global WPAR data is accessible from the global WPAR.

  • For Z series you can only install 64-bit Agent. Compatible 64-bit for libgcc_s.so.1 and libstdc++.so.5 libraries are required to be installed for Z series.

Operating system

Supported version

Architecture and notes

AIX 7.1

64-bit hardware, 64-bit kernel, POWER

7.2

64-bit hardware, 64-bit kernel, POWER

Linux CentOS

6.7 to 6.9
  • x86
  • x86_64 
7.2 to 7.3

x86_64

Citrix Xen

6.5

x86_64

7.2 x86_64

HP-UX

11i (B11.31)

64-bit, PA-RISC

HP-UX



11iv3 (B11.31)

Itanium
HP-IVM 3.5*

HP Integrity Virtual Machines Manager

Red Hat Enterprise Linux

6.7 to 6.9
  • x86
  • x86_64
  • ppc64 (Big Endian)
  • zSeries(s390x)
7.2 to 7.4
  • x86-64
  • ppc64le (Little Endian)
  • ppc64 (Big Endian)
  • zSeries(s390x)

Oracle Linux

6.7 to 6.9
  • x86
  • x86_64 (including UEK)
7.2 to 7.3

x86_64 (including UEK)

Oracle Solaris

11.0 to 11.3

64-bit SPARC, x86_64

Note: For Oracle Solaris Sparc servers, the installation of Capacity Agents on non-global zones is not supported.

SUSE Linux Enterprise Server

11.x
  • x86
  • x86_64
  • POWER, zSeries are supported (SP04)

Note: SUSE Linux Enterprise Server support includes support for all point releases within the series (for example: Open Source Xen covers support for 11.x).

12.0 to 12 SP2

x86_64

Microsoft Windows for Servers

2012*

(including core server)

x86_64

 

2012 R2

(including core server)

x86_64

2016

(including core server)

x86_64
Microsoft Windows 10  
Microsoft Hyper-V Server 2012*

x86_64

2012 R2 x86_64
2016 x86_64
Ubuntu


14.04 LTS
 
EM64T (x86_64)
16.04 LTS

EM64T (x86_64)

Oracle VM Server 3.3 and 3.4 x86_64
RHEV 4.0 x86_64

Patch requirements for Agents

The following table lists the required operating system patches.

Patch for ↓ Description ↓
Solaris →


Requirement for ↓

Description ↓

Package: libpool.so.1

For Solaris 11:

  • SUNWpool
  • SUNWpoold
  • SUNWpoolr

To verify that these packages are installed, run the following command:

> pkginfo | grep SUNWpool


Presentation Server

Microsoft Windows

Component

Requirement

User Rights

Administrative privileges

Supported versions of Microsoft Windows

Microsoft Windows 2016

  • Microsoft Windows 2016 Standard Edition (64-bit)
  • Microsoft Windows 2016 Datacenter Edition (64-bit)

Microsoft Windows 2012 

  • Microsoft Windows 2012 Standard Edition (64-bit)  
  • Microsoft Windows 2012 Datacenter Edition (64-bit)  
  • Microsoft Windows 2012 R2 Standard Edition (64-bit)  
  • Microsoft Windows 2012 R2 Datacenter Edition (64-bit)  

Microsoft Windows 2008

  • Microsoft Windows 2008 R2 Standard Edition (64-bit)  
  • Microsoft Windows 2008 R2 Datacenter Edition (64-bit)   
  • Microsoft Windows 2008 R2 Enterprise Edition (64-bit)  

Note

Installing the Presentation Server on the Windows computer with the Korean locale is not supported as PostgreSQL 9.4.4 is not supported on the same.

Linux

Component

Requirement

User Rights

A non-root user who has modification permissions to specific directories and files.
A user with root privileges cannot install the Presentation Server.

Supported versions of Linux

  • Red Hat Enterprise Linux versions 6.7, 6.8, 6.9, 7.2, 7.3 (64-bit versions)
  • SUSE Linux Enterprise Server versions 11 SP 3, 11 SP 4, 12, 12 SP 2 (64-bit versions)
  • Oracle Linux Server versions 6.8 and 7.3 (64-bit versions)

Supported kernel versions

Linux version Supported kernel version
Red Hat Enterprise Linux 6.7 2.6.32-573

Red Hat Enterprise Linux 6.8

2.6.32-642
Red Hat Enterprise Linux 6.9 2.6.32-696
Red Hat Enterprise Linux 7.2 3.10.0-327
Red Hat Enterprise Linux 7.3 3.10.0-514
SUSE Linux Enterprise Server 11 SP 3 3.0.76-0.11.1
SUSE Linux Enterprise Server 11 SP 4 3.0.101-88.1
SUSE Linux Enterprise Server 12 3.12.28-4.6
SUSE Linux Enterprise Server 12 SP 2 4.4.21-81
Oracle Linux Server 6.8 Unbreakable Enterprise Kernel (UEK) Release 4
Oracle Linux Server 7.3 Unbreakable Enterprise Kernel (UEK) Release 4


Notes

  • BMC products are certified for use on supported operating system versions. BMC does not explicitly test for OS patches/updates that are released after a BMC product is released.
  • BMC products should work fine with minor updates to these supported operating systems. For assistance, contact BMC Customer Support.

Red Hat subscription 

The product requires some additional libraries to be present on the system (see list below).

The preferred method to add any missing libraries is to use the yum command to fetch the necessary library packages from the RHN (Red Hat Network) repository via the Internet.  To use this method, a Red Hat subscription is needed. Register the system by clicking System > Administration > Red Hat Subscription Manager in the menu on the server itself.  After registering the system, you can use yum install to download and install the required libraries from the RHN.

X Windows 

If you are installing the Presentation Server using the graphical user interface, you must install X Windows.

On the Red Hat Enterprise Linux terminal, type yum grouplist and check that X Window System is listed.  If not, then run yum groupinstall 'X Window System' to install the necessary packages.   

Required libraries

Ensure that the following libraries are present to install the Presentation Server.  To install the libraries, use the following commands.

Library

Command to install the library on RHEL

Command to install the library on SUSE

libXtst (32-bit)

libXtst (64-bit)

yum install libXtst.i686 libXtst.x86_64

    libXtst-1.0.1-3.1

    libX11-devel-1.0.3-11.el5

N/A

glibc (32-bit)

glibc (64-bit)

yum install glibc.i686 glibc.x86_64

    glibc-2.12.x86_64

    glibc-2.12-1.107.el6.i686

    glibc-devel-2.5-65

zypper install glibc-32bit glibc

libstdc++ (32-bit)

libstdc++ (64-bit)

yum install libstdc++.i686 libstdc++.x86_64

zypper install libstdc++-32bit libstdc++

compat-libstdc++-33 (32-bit)

compat-libstdc++-33 (64-bit)

yum install compat-libstdc++-33.i686 

    compat-libstdc++-33.x86_64

    compat-libstdc++-33-3.2.3-69.e16.i686 

zypper install libstdc++33-32bit libstdc++33 

compat-libstdc++-296 (32-bit)

yum install compat-libstdc++-296.i686

N/A

pam (32-bit)

pam (64-bit)

yum install pam.i686 pam.x86_64

    pam-1.1.1-13.e16.i686

zypper install pam-32bit pam

libgtk-x11-2 (32-bit)

yum install libgtk-x11-2.0.so.0

N/A

Note

On a Linux setup, ensure that glibc-2.12.x86_64 (or later versions) is installed on the computer where you plan to install Presentation Server.

Supported databases and operating systems for TLS enabled communication

Requirements for TrueSight Capacity Optimization databases that need to communicate in TLS 1.2 mode

Database

Version

Oracle
  • Oracle database version:
    • For Linux: 11.2.0.4.2 Patch 19207156  
      and later
    • For Windows: 11.2.0.4.10 Patch 19651773
  • Oracle Client version is 12c or later

Also, see Oracle database documentation .

PostgreSQL

PostgreSQL 9.4 and later

Microsoft SQL Server1

2012 R2

Also, see TLS 1.2 support for Microsoft SQL Server‎ .

1 - Only supported as external database.


Operating system requirements for TrueSight Capacity Optimization components that need to communicate in TLS 1.2 mode

Operating system

Version

Supported architecture

Red Hat Enterprise Linux

6.x

x86_64

7.x

x86_64

Oracle Linux

6.x

x86_64

7.x

x86_64

Linux CentOS

6.x

x86_64

7.x

x86_64

SUSE Linux Enterprise

12 x86_64

Supported Oracle clients

Computers or VMs that host the TrueSight Capacity Optimization Application Server or ETL Engine server components must be running a supported Oracle client with the following packages, components, and configurations:

Oracle Client install options1

Oracle Client configurations

  • Oracle Net
  • Oracle Database Utilities
  • Oracle JDBC/THIN Interfaces
  • SQL*Plus
  • SQLLDR
  • Oracle Call Interfaces

1 These options are available only while performing a Custom installation of the Oracle Client.

  • Oracle Client 11.2.x, 64-bit

  • Oracle Client 12.1.x, 64-bit

Note

  • TrueSight Capacity Optimization does not support the Oracle Instant Client.
  • You must use Oracle 12c R1 with CentOS 7.x, Red Hat Enterprise Linux 7.x, and Oracle Enterprise Linux 7.x because Oracle 11g R2 is not supported on these operating systems.
Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Stefan Antelmann

    For Suse on the agent we have been required to install the 32 bit version of glibc. If the OS is running 64 bit, I recommend to install this libraries.



    ksh,glibc,glibc-32bit

    Aug 22, 2018 08:56