Supported platforms for version 8.8

This topic lists the OS platform versions that are supported by BMC Server Automation. You can use the individual component installers to manually install or upgrade a component, if the UPI does not support your OS version.

Changes in OS support in BMC Server Automation version 8.8

This section lists the changes in OS support in BMC Server Automation version 8.8.

New platform support for product components

The following table lists new combinations of operating systems and components that are supported in BMC Server Automation 8.8. (A plus sign (plus) indicates support.)

Platform / Version

RSCD
Agent

Network
Shell
(NSH)

Application
Server

PXE and 
TFTP

Provisioning

Patch

VirtualizationConsole
CentOS Linux 7.x(plus)(error)(error)(error)(error)(error)(error)(error)
Citrix XenServer 6.5(error)(error)(error)(error)(error)(error)(plus)(error)
Debian 7.x(plus)(plus)(error)(error)(error)(error)(error)(error)
Debian 8.x(plus)(plus)(error)(error)(error)(plus)(error)(error)
Microsoft Windows version 10(plus)(plus)(error)(error)(error)(plus)(error)(plus)
Oracle Enterprise Linux 7.x(plus)(plus)(plus)(error)(error)(error)(error)(error)

Ubuntu Linux Server 15.1 and 16.04

(plus)(plus)(error)(error)(error)(error)(error)(error)
VMware ESX Server 5.0(error)(error)(error)(error)(plus)(error)(error)(error)
Dell iDRAC 6,7, and 8(error)(error)(error)(error)

(plus)

(error)(error)(error)

Deprecated platform support in version 8.8

BMC Server Automation 8.8 no longer supports Red Hat Enterprise Linux 5.x for the Application Server.

BMC Server Automation 8.8 no longer supports IBM AIX 5.1 for patch management.

BMC Server Automation 8.8 no longer supports the following platforms on all components:

  • Cent OS 4.x and 5.x
  • Debian 5.x and 6.x (OS end of life)
  • Windows Server 2003 and Windows Server 2003 with Virtual Center
  • Oracle Enterprise Linux 4.x
  • Red Hat Enterprise Linux 4.0 (and zSeries)
  • Solaris 9
  • SUSE Linux Enterprise Server 9.x
  • SUSE zSeries 9.x
  • Ubuntu 10.x and 11.x (OS end of life)
  • VMware ESX 3.x and 4.x (OS end of life)

BMC Server Automation 8.8 no longer supports the following platforms for virtualization:

  • VMware ESXi Server (via vCenter Server) 3.x and 4.x
  • VMware vCenter Server 4.0

Supported platforms for installers

The following sections provides the list of supported platforms for installing or upgrading.

Supported platforms for Unified Product Installer (UPI)

This section provides the list of supported platforms for installing or upgrading using the unified product installer.

OS platformVersionArchitecture / Hardware
Red Hat Enterprise Linux6.x

x64 (64-bit native)

 

7.x

x64 (64-bit native)

SUSE Enterprise Linux

11

x64 (64-bit native)

 12.x

x64 (64-bit native)

Microsoft Windows Server

2008 R2 SP1

2012

2012 R2

x64 (64-bit native)

Supported platforms for native installers

Supported platforms for IBM AIX native installers

Operating system

BFF RSCD agent install

BFF NSH install

AIX 5.2

Yes

Yes

AIX 5.3

Yes

Yes

AIX 6.1

Yes

Yes

AIX 7.1

Yes

Yes

 Supported platforms for Linux native installers

Operating system

RPM RSCD agent install

RPM NSH install

SUSE 10.x x86

Yes

Yes

SUSE 11.x x86

Yes

Yes

SUSE 10.x x64

Yes

Yes

SUSE 11.x x64

Yes

Yes

SUSE 12.x x64 (64-bit)YesYes
SUSE zSeries 10.xYesNo
SUSE zSeries 11.xYesNo

Red Hat Enterprise Linux 6.0 x86

Yes

Yes

Red Hat Enterprise Linux 6.0 x64YesYes
Red Hat Enterprise Linux 7.0 x64YesYes
Red Hat Enterprise Linux 6.0 (zSeries)YesNo
Cent OS 5.2 x86YesYes
Cent OS 5.2 x64YesYes

Oracle Enterprise Linux 4.0 x86

Yes

Yes

Oracle Enterprise Linux 5.0 x86

Yes

Yes

Oracle Enterprise Linux 6.0 x86

Yes

Yes

Oracle Enterprise Linux 4.0 x64

Yes

Yes

Oracle Enterprise Linux 5.0 x64

Yes

Yes

Oracle Enterprise Linux 6.0 x64

Yes

Yes

 Supported platforms for Oracle Solaris SVR4 package native installers

Operating system

Package RSCD agent install

Package NSH install

Solaris 10 x64

Solaris 10 x86

Solaris 10 SPARC (sun4v)

Solaris 10 SPARC (sun4us)

YesYes

Solaris 11 x64

Solaris 11 x86

Solaris 11 SPARC (sun4u)

YesYes

Solaris 11.x x64

Solaris 11.x SPARC (sun4v)
YesYes

Supported platforms for Debian package native installers

Operating system

Package RSCD agent install

Package NSH install

Ubuntu 12YesYes

For information about using these installers, see:

Back to top

Supported platforms for individual components

This section provides the list of supported platforms for each BMC Server Automation component or capability.

For details about the specific installation programs required for each platform and each component, see Installation programs for BMC Server Automation.

Note

The most current supported platforms and compatible versions of various components of BMC Server Automation and third-party products, is listed through the BMC Solution and Product Availability and Compatibility Utility

Agent support

This section provides the list of supported platforms for Agents.

OS platformVersionArchitecture /
Hardware 

CentOS Linux

6.x

x86

x64 (64-bit native)

 7.xx64
Debian7x64
 8.1x64

HP-UX

11.23

PA-RISC

IA64 (an Aries
emulator installation
is required)

 11.31

PA-RISC

IA64 (an Aries
emulator installation
is required)

IBM AIX5.1pSeries

5.2pSeries
 5.3pSeries
 6.1pSeries
 7.1pSeries
IBM VIOS2.1 and 2.2 
Microsoft WindowsWindows Server 2008

x86

x64 (64-bit native)

Windows Server 2012

x64

Windows Server 2012 R2

x64

Oracle Enterprise Linux

5.x

x86

x64 64-bit

6.x

x86

x64 64-bit

 7.xx64

Oracle Solaris

10

x86

x64

64-bit supporting 32-bit binaries

SPARC (sun4u)

SPARC (sun4v)

SPARC (sun4us)

11

x86

x64

SPARC (sun4u)

 11.x

x64

SPARC (Sun4v)

Red Hat Enterprise Linux

5.x

x86

x64 (64-bit  native)

zSeries (64-bit  native)

6.x

x86

x64 (64-bit  native)

zSeries (64-bit  native)

7.x

x64 (64-bit  native)

SUSE Linux Enterprise Server

10.x

x86

x64 64-bit

zSeries 64-bit 

11.x

x86

x64 64-bit

zSeries 64-bit 

 12.x

x64 64-bit

zSeries 64-bit

Ubuntu Linux Server

12.x  
 14.x 
 15.1 
 16.04 

Back to top

Application Server support

This section provides the list of supported platforms for Application Servers.

OS platformVersionArchitecture /
Hardware 
Microsoft WindowsWindows Server 2008 R2 SP1

x64 (64-bit native)

 Windows Server 2012x64 (64-bit native)

Windows Server 2012 R2

x64 (64-bit native)

Red Hat Enterprise Linux

6.x

x64 (64-bit native)

 7.x

x64 (64-bit native)

SUSE Linux Enterprise Server11.xx64 (64-bit native)
 12.xx64 (64-bit native)
Oracle Enterprise Linux5.5x64 (64-bit native)
 6.xx64 (64-bit native)
 7.xx64

Back to top

Console support

This section provides the list of supported platforms for the console.

Note

Although the following table lists several 32-bit platforms, note that the unified product installer supports only 64-bit platforms. If you install the Console as a separate component, BMC recommends installing it on a 64-bit platform.


OS platformVersionArchitecture /
Hardware 

Microsoft Windows

Windows Server 2008 R2 SP1

x64 (64-bit)

Windows Server 2012x64 (64-bit native)

Windows Server 2012 R2

x64 (64-bit native)

Windows 7 SP1

x86 (32-bit)

x64 (64-bit)

Windows 8

x86 (32-bit)

x64 (64-bit)

 10x64

Red Hat Enterprise Linux

6.x

x86 

x64 (64-bit native)

 7.x

x64 (64-bit native)

SUSE Linux Enterprise Server11.x

x86

x64 (64-bit native)

 12.x

x64 (64-bit native)

Back to top

Database support

This section provides the list of database platforms supported for BMC Server Automation.

Database typeSupported versions
Oracle

Enterprise Edition (EE) and Standard Edition (SE):

  • 11g R2
  • 11g R2 RAC
  • 12c
  • 12c RAC

(not recommended for production setup) Express Edition (XE)

Note

The following databases do not have support for IPv6 in BMC Server Automation:

  • Oracle 11g R2 RAC
  • Oracle 12c
  • Oracle 12c RAC

If you plan to use Oracle version 11.2.0.2 as the database for BMC Server Automation, before you install BMC Server Automation, you must install the appropriate patch to Oracle 11.2.0.2:

  • Linux and UNIX platforms: Patch 9620994
  • Windows 32 and 64-bit platforms: Oracle 11.2.0.2 Patch 4 (or later) bundle, which contains Patch 9620994.
 To determine if this patch is installed on your Oracle 11.2.0.2 database:
  1. On the database server, ensure that the ORACLE_HOME variable is set to the 11.2.0.2 installation directory.
  2. Run the command to locate Patch 9620994:
    • Linux and UNIX platforms:
      $ORACLE_HOME/OPatch/opatch lsinventory | grep 9620994
    • Windows:
      %ORACLE_HOME%\OPatch\opatch lsinventory | findstr 9620994
Microsoft SQL Server

  • 2008 (EE, SE)
  • 2008 Cluster (EE, SE)
  • 2008 R2 (EE, SE)
  • 2008 R2 Cluster (EE, SE)
  • 2012 (EE, SE)
  • 2012 Cluster (EE,SE)
  • 2012 R2 (EE, SE)
  • 2014 (EE, SE)
  • 2016 (EE, SE)

Note

For SQL Server to support TLS 1.2, certain client components and driver updates are required, as discussed in the following Microsoft article: https://support.microsoft.com/en-us/kb/3135244

Important

BMC Server Automation does not support using an encrypted Microsoft SQL Server database connection at the time of installation or upgrade. However, after the product is installed or upgraded successfully, BMC Server Automation can use an encrypted connection to communicate with the Microsoft SQL Server database.

For steps on enabling and disabling an encrypted connection to your SQL database server, see Encrypting your database connection.

Back to top

NSH support

This section provides the list of supported platforms for Network Shell.

Note

Although the following table lists several 32-bit platforms, note that the unified product installer supports only 64-bit platforms. If you install Network Shell as a separate component, BMC recommends installing it on a 64-bit platform.


OS platformVersionArchitecture /
Hardware 
CentOS Linux5.x

x86

x64 (64-bit native)

Debian7x64
 8.1x64

HP-UX

11.23

PA-RISC

IA64

 11.31

PA-RISC

IA64

IBM AIX

5.2pSeries
 5.3pSeries
 6.1pSeries
 7.1pSeries
Microsoft WindowsWindows Server 2008x64 (64-bit native)
 Windows Server 2008 R2x64 (64-bit native)
 Windows Server 2012x64 (64-bit native)
 Windows Server 2012 R2x64 (64-bit native)
 2012x64 (64-bit native)
 2012 R2x64 (64-bit native)

Oracle Enterprise Linux

5.x

x86

x64 (64-bit native)

6.x

x86

x64 (64-bit native)

 7.xx64

Oracle Solaris

10

SPARC (sun4u)

SPARC (sun4v)

SPARC (sun4us)

x86

x64

11

SPARC (sun4u)

x86

x64

 11.x

x64

SPARC (Sun4v)

SUSE Linux Enterprise Server

10.x

x86

x64 (64-bit native)

11.x

x86

x64 (64-bit native)

 12.x

x64 (64-bit native)

Ubuntu Linux Server

12.x 
 14.x 
 15.1 
 16.04 
Red Hat Enterprise Linux6.xx64 (64-bit native)
 7.xx64 (64-bit native)

Back to top

Patch management support

This section provides a list of platforms supported for patch management.

Important

  • The following OS versions are not supported as patching targets for version 8.8, if the target system has BMC Server Automation agent version 8.8 installed:

    • RedHat Enterprise Linux version 5 (and earlier)
    • Oracle Enterprise Linux version 5 (and earlier)
    • SuSE version 10 (and earlier)
     
    Workaround: For targets on any of these platforms, either update the version 8.8 agents with the component template fix available from Knowledge Article 000120867 or use an earlier version of the agent (for example, version 8.6 or 8.7 P4).
  • Only offline patch catalogs can be created for OEL platforms.

This section provides the list of platforms supported for patch management from an 8.8 Application Server.


OS platformVersionArchitecture /
Hardware 
IBM AIX5.2pSeries
 5.3pSeries
 6.1pSeries
 7.1pSeries
Microsoft WindowsWindows Server 2008

x86

x64 (64-bit native)

 

Windows Server 2008 R2x64 (64-bit native)

 

Windows Server 2012x64 (64-bit native)

 

Windows Server 2012 R2

x64 (64-bit native)

Oracle Enterprise Linux

5.x***

 

x86

x64 (64-bit native)

 

6.x

x86

x64 (64-bit native)

Oracle Solaris

10

SPARC (sun4u)

SPARC (sun4v)

SPARC (sun4us)

x86

x64

 11*

SPARC (sun4v)

x86

Red Hat Enterprise Linux

5.x***

x86

x64 (64-bit  native)

zSeries (64-bit  native)

 

6.x

x86

x64 (64-bit native)

zSeries (64-bit native)

 7.x

x64 (64-bit native)

SUSE Linux Enterprise Server

10.x***

x86

x64 (64-bit native)

zSeries  (64-bit  native)

 

11.x

x86

x64 (64-bit native)

zSeries  (64-bit  native)

 12

x64

zSeries  (64-bit  native)

Ubuntu Linux Server12

x86

x64

 14

x86

x64

Debian8

x86

x64

HP-UX**11.23

PA-RISC

IA64

 11.31

PA-RISC

IA64

CentOS Linux**

5.x

x86

x64 (64-bit native)

 

 6.x

x86

x64 (64-bit native)

* For Solaris 11, a separate script-based solution is provided. See How to perform script-based patch analysis for Solaris 11.

** For HP-UX and CentOS Linux, a separate script-based solution called Vendor Patch Content (VPC) is provided. See How to perform HP-UX or CentOS patch analysis using Vendor Patch Content.

*** Supported for 8.7 P4 agents, or for agent versions with the component template fix available from Knowledge Article 000120867.

Supported platforms for storing the patch repositories of patch catalogs

    MultiExcerpt named 'repositoryMatrix' was not found
The multiexcerpt named 'repositoryMatrix' was not found. Please check the page name and MultiExcerpt name used in the MultiExcerpt Include macro.

Back to top

Patch offline downloader support

This section provides the list of supported platforms for running the patch offline downloader.

OS platformVersionArchitecture /
Hardware
Microsoft WindowsWindows Server 2008 R2 SP1x64 (64-bit native)
 Windows Server 2012x64 (64-bit native)
 Windows Server 2012 R2x64 (64-bit native)
IBM AIX

6.1

pSeries
 7.1pSeries
Oracle Solaris10SPARC (64-bit)
 11.xSPARC (64-bit)
Red Hat Enterprise Linux6.x

32-bit

64-bit

 7.x

32-bit

64-bit

SUSE Linux Enterprise Server10.x

x86

x64 (64-bit native)

 

11.x

x64 (64-bit native)
 12.xx64 (64-bit native)
Oracle Enterprise Linux5.5

32-bit

64-bit

 6.x

32-bit

64-bit


Back to top

Target platforms supported for bare-metal provisioning

This section provides the list of platforms supported for bare-metal provisioning.

OS platformVersionArchitecture /
Hardware 

Citrix XenServer

5.5.0

x86

x64

5.6.0

x86

x64

6.0.0

x86

x64

HP-UX

11.23

PA-RISC

IA64

 11.31

PA-RISC

IA64

IBM AIX

5.2pSeries
 5.3pSeries
 6.1pSeries
 7.1pSeries
Microsoft WindowsWindows Server 2008

x86

x64 (64-bit native)

Windows Server 2008 R2

x64 (64-bit native)

 Windows Server 2008 R2 SP1EFI

Windows Server 2012x64 (64-bit native)
  EFI
 Windows Server 2012 R2x64 (64-bit native)
  EFI

Oracle Enterprise Linux

5.x

x86

x64 (64-bit native)

6.x

x86

x64 (64-bit native)

Oracle Solaris9

SPARC (sun4u)


10

SPARC (sun4u)

SPARC (sun4v)

SPARC (sun4us)

x86

x64

11.x

SPARC (sun4u)

SPARC (sun4v)

x64

Red Hat Enterprise Linux

5.x

x86

x64 (64-bit  native)

zSeries (64-bit  native)

6.x

x86

x64 (64-bit native)

EFI

 7.x

x64 (64-bit native)

EFI

SUSE Linux Enterprise Server

10.x

x86

x64 (64-bit native)

11.x

x86

x64 (64-bit native)

 11.xEFI
 12.x

x64 (64-bit native)

EFI

VMware ESXi Server

4.1

 
 

5.0

 
Ubuntu Linux Server12.04 
 14.04 
Dell iDRAC 6Not Applicable

7Not Applicable

8Not Applicable

Back to top

TFTP/PXE Server support

This section provides the list of platforms for use as a TFTP/PXE server.

Note

Although the following table lists several 32-bit platforms, note that the unified product installer supports only 64-bit platforms. If you install the TFTP/PXE server as a separate component, BMC recommends installing it on a 64-bit platform.  


OS platformVersionArchitecture /
Hardware 

Microsoft Windows

Windows Server 2008 R2 SP1x64 (64-bit native)

Windows Server 2012x64 (64-bit native)
 Windows Server 2012 R2

x64 (64-bit native)

Oracle Enterprise Linux

5.5

x64 (64-bit native)

6.x

x64 (64-bit native)

Red Hat Enterprise Linux

6.x

x64 (64-bit native)

 7.x

x64 (64-bit native)

SUSE Linux Enterprise Server

11.x

x64 (64-bit native)

12.x

x64 (64-bit native) 

Back to top

Virtualization support

This section provides the list of platforms supported as virtualized environments that can be provisioned.

Removal of support

Beginning in BMC Server automation 8.8, versions of VMware ESX server prior to version 5.0 are no longer supported.

OS platformVersionArchitecture /
Hardware 

Citrix XenServer

5.5.0 

5.6.0 

6.0 
 6.5 

IBM LPAR

Power5 (Enterprise Edition Only) 
 Power6 (Enterprise Edition Only)
 
 Power7 (Standard and Enterprise Edition)
 

Microsoft Hyper-V 3.0

Note: Generation 1 and Generation 2 Hyper-V templates from Microsoft are supported.

SCVMM 2012 SP1 
SCVMM 2012 R2 

Microsoft Hyper-V 4.0

Note: Generation 1 and Generation 2 Hyper-V templates from Microsoft are supported.

SCVMM 2012 R2 

Oracle Solaris Zones

10 u4

x86

SPARC

Red Hat Enterprise Virtualization Manager for Servers

(RHEV Manager)

3.0 
VMware ESXi Server (via vCenter Server)5.0 
 5.1 
 5.5  
VMware vCenter Server

5.0

x64 
 

5.1

x64
 5.5 x64
 6.0x64

Back to top

Virtual guest OS support

Removal of support

Beginning in BMC Server automation 8.8, versions of VMware ESX server prior to version 5.0 are no longer supported.

The following table lists the various guest operating systems supported by each server version:

 VMware vCenter Citrix XenRHEVHyper-V SCVMM

 

5.0

5.1

5.5

6.0

5.5

5.6

6

6.5

3.0

2012
SP1

2012
R2

Windows
2008 (32-bit)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

Windows
2008 (64-bit)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

Windows
2008 R2 (64-bit)

(tick)

(tick)

(tick)

(tick)

(error)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

Windows Server
2012

(error)

(tick) 1

(tick)

(tick)

(error)

(error)

(error)

(error)

(error)

(tick)

(tick)

Windows Server
2012 R2

(error)

(tick)

(tick)

(tick)

(error)

(error)

(error)

(error)

(error)

(tick)

(tick)

RHEL 5.x (32-bit)

(tick)

(tick)

(tick)

(tick)

(error)

(tick)

(tick)

(tick)

(error)

(error)

(tick)

RHEL 5.x (64-bit)

(tick)

(tick)

(tick)

(tick)

(error)

(tick)

(tick)

(tick)

(error)

(error)

(tick)

RHEL 6.x (32-bit)

(tick)

(tick)

(tick)

(tick)

(error)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

RHEL 6.x (64-bit)

(tick)

(tick)

(tick)

(tick)

(error)

(tick)

(tick)

(tick)

(tick)

(tick)

(tick)

RHEL 7.x (64-bit)

(tick)

(tick)

(tick)(tick)

(error)

(error)

(error)

(error)

(tick)

(error)

Only RHEL 7.1
GEN2 template

Ubuntu

(tick)

(tick)

(tick)(tick)

(error)

(error)

(error)

(error)

(error)

(error)

(error)


1 If Guest OS customization for Windows Server 2012 is not completed, reboot the virtual machine manually, as described in VMware knowledge base article 2037366.

2 The deployPkg plug-in is not installed by default with open-vm tools, which may cause the guest customization to fail. For steps to install the deployPkg plug-in, see the following VMware knowledge base articles:

For more information on guest operating support customization, see the Guest OS Customization Support Matrix available from the VMware online technical documentation.

Back to top

Supportability considerations for BMC Server Automation and BMC Cloud Lifecycle Management

This section lists the supportability considerations when using BMC Server Automation along with BMC Cloud Lifecycle Management. 

Removal of support

Beginning in BMC Server automation 8.8, versions of VMware ESX server prior to version 5.0 are no longer supported.

Platform
BMC Server Automation
BMC Cloud Lifecycle Management
VMware

VMware 5.0

VMware 5.1

VMware 5.5

VMware 6.0

VMware 5.0

IBM

IBM pSeries 5

IBM pSeries 6

IBM pSeries 7

Not supported

IBM pSeries 6

IBM pSeries 7

Microsoft Windows Hyper-V

SCVMM 2008 R2

SCVMM 2012 SP1 GA

SCVMM 2012 R2

Not supported

SCVMM 2012 SP1 GA

SCVMM 2012 R2

 

Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Ankur Maloo
    https://docs.bmc.com/docs/ServerAutomation/88/planning/system-requirements/supported-platforms-for-version-8-8#Supportedplatformsforversion8.8-Newplatformsupportforproductcomponents shows no RSCD agent Support for Cent OS 7.x
    However; https://docs.bmc.com/docs/ServerAutomation/88/planning/system-requirements/supported-platforms-for-version-8-8#Supportedplatformsforversion8.8-Agentsupport shows Cent OS 7.x supported OS for RSCD Agent. Can someone please fix this?
    Jun 15, 2017 02:14
    1. Moiz Nalwalla

      Sure, I'll work on fixing this.

      Sep 25, 2017 03:47
    1. Moiz Nalwalla

      After confirming with the team i have updated the 8.8 and 8.9 docs to reflect the correct support for Cent OS 7.x. We support only Agent for Cent OS 7.x and not NSH. Let me know if it looks OK now.

      Oct 05, 2017 02:21
  2. Raghunandan swarup Sahoo

    As per the information on Spac, the CentOS 7.x is not a supported platform for NSH and is supported for RSCD agent.

    https://customerapps.bmc.com/spac/o/welcome.html?F700002937=LPV95.8.8.00

    Please have a look and update the documentation accordingly.
    Jun 15, 2017 04:03
    1. Moiz Nalwalla

      After confirming with the team i have updated the 8.8 and 8.9 docs to reflect the correct support for Cent OS 7.x. We support only Agent for Cent OS 7.x and not NSH. Let me know if it looks OK now

      Oct 13, 2017 07:39