Service Pack 4 (8.2.04)

This section contains information about Service Pack 4 for BMC Server Automation 8.2.

Tips

For information about known issues, see Known issues and workarounds.

Click here to create a PDF containing only content related to Service Pack 4.

About Service Pack 4

Service Pack 4 includes full installers for all components. You can download the service pack files from the BMC Electronic Product Distribution (EPD) website. The version number shown on EPD is 8.2.04.

Note

The installers for BMC Vendor Patch Management, and BMC BladeLogic Atrium Integration were not upgraded for version 8.2 SP4.

  • If you have installed version 8.2 SP1 for any of these programs, you need not upgrade to Service Pack 4 (8.2.04) to obtain those programs.
  • To upgrade to version 8.2 SP1 of these programs, download them from the BMC BladeLogic Server Automation Suite 8.2.04 item on the EPD website.

Considerations for patch management

If you are using Microsoft Windows, review the following considerations for patch management.

Resolving a potential RSCD Agent installation problem

On BMC Server Automation 8.2, if the target system is in a pending reboot state (for example, from a previous patch or other software installation), then the default MSI installer supplied with the agent disallows the installation.

Starting with version 8.2 SP2, the PENDINGREBOOTFORCE flag allows the MSI installer to ignore this state. After confirming that the pending reboot state on the target is not a result of a previous RSCD installation, setting PENDINGREBOOTFORCE=1 ignores the pending reboot state and proceeds with the installation. The following is a command-line sample for the MSI installer:

msiexec /I RSCD82-SP4.WIN32.msi /qn REBOOT=ReallySuppress PENDINGREBOOTFORCE=1

Contents of the service pack

The following topics describe the updates included and the issues corrected in this service pack.

Downloading the files

 Click here to see the procedure for obtaining the service pack files.

    MultiExcerpt named 'download_files' was not found
The multiexcerpt named 'download_files' was not found. Please check the page name and MultiExcerpt name used in the MultiExcerpt Include macro.

Fresh Installation of the Service Pack

After running 8.2 SP4 external files, run the scripts found in the 82-SP4-SQL_Update_Scripts.zip file. This file is available in the BMC Server Automation 8.2.04 section of EPD. Run these scripts as the BMC Server Automation database owner (as provided to blasadmin).

Upgrading to the service pack

To upgrade to this service pack, complete the tasks described in the following sections.

Review the supported upgrade paths

 Click here to see a list of supported upgrade paths.

    MultiExcerpt named 'supported_upgrade_paths' was not found
The multiexcerpt named 'supported_upgrade_paths' was not found. Please check the page name and MultiExcerpt name used in the MultiExcerpt Include macro.

Review the upgrade sequence

Review the upgrade considerations and the upgrade sequence.

 Click here to review the upgrade sequence.

    MultiExcerpt named 'upgrade_sequence' was not found
The multiexcerpt named 'upgrade_sequence' was not found. Please check the page name and MultiExcerpt name used in the MultiExcerpt Include macro.

Run the service pack installers

See the following topics for information about running the specific installers.

Run database migration

After upgrading the application server, you must upgrade the database through the Data Migration Manager. This will upgrade the database to 8.2 SP1.

Note

The database migration task is required only if you are upgrading from a pre-8.2 SP1 version.
If you are upgrading from version 8.2 SP1 or later, database migration is not required.

You can migrate to BMC Server Automation version 8.2 SP4 only  from version 7.6 and later versions. If you are running a version earlier than 7.6, you must first upgrade to version 7.6. See the BMC Server Automation Installation Guide for version 7.6 for information about upgrading earlier versions.

    MultiExcerpt named 'migrating_data' was not found
The multiexcerpt named 'migrating_data' was not found. Please check the page name and MultiExcerpt name used in the MultiExcerpt Include macro.

After completing the database migration, you must run the SQL scripts found in the 82-SP4-SQL_Update_Scripts.zip file, provided on the 8.2 SP4 EPD page. These scripts upgrade the database from 8.2 SP1 to 8.2 SP4. Run these scripts as the BMC Server Automation database owner (as provided to blasadmin). For more detailed instructions, see Running the SQL update scripts

For more information, see Review the supported upgrade paths.

Upgrade the RSCD agents

See the following topics for information about upgrading the RSCD agents:

Was this page helpful? Yes No Submitting... Thank you

Comments