System requirements

Support for third-party products

To receive full support for a BMC product, you must have that product installed in a supported environment, as specified in the BMC product documentation. If a third-party vendor cancels support for one of its products (such as an operating system or subsystem), and that third-party product integrates or interacts with the BMC product you have licensed, you must upgrade to a supported version of that third-party product before BMC Customer Support can provide you with support for the affected BMC product. For further information, see BMC's product support policy.

The following table lists the product requirements and supported resources:

Product requirements and supported resources

Resource

Requirements

Comments

Real User Analyzer

PATROL for Application Management version 10.x is compatible with the Real User Analyzer that is available with:

  • End User Experience Management version 2.7.
  • Real End User Experience Software Edition 10.x

None

Java

Supports any of the following Java versions:

  • Oracle Java 8.x
  • OpenJDK 8.x

Note: For the latest announcement on BMC’s Java Support policies for TrueSight monitoring solutions, see Java support for TrueSight monitoring solutions

None

ProactiveNet Performance Management

PATROL for Application Management is compatible with ProactiveNet Performance Management version 9.5 or later.

None

Other required PATROL products

PATROL installation utility version 7.5.60 or later

None

Other optional PATROL products

  • PATROL Configuration Manager
  • PATROL KM for Event Management

PATROL Configuration Manager and PATROL KM for Event Management are required if you plan to modify the product configuration.

Security

PATROL for Application Management operates in all PATROL security levels.

None

OS accounts on Windows

Use the following guidelines when setting up a Windows account for PATROL:

  • Before installing PATROL, create a dedicated user account that is either a local or a domain account.
  • Accounts that are on a domain controller must be members of the domain Administrators group.
  • Do not use a built-in Administrator account.
  • If you are using a domain account, you must specify the NT domain along with the user name.

None

OS accounts on UNIX or Linux

Use the following guidelines when setting up a UNIX or Linux account for PATROL:

  • The account .login, .profile, .cshrc, and .kshrc files must not contain any customizations, such as aliases, nondefault prompts, and umask settings other than 022.
    Do not use the root account.
  • The account must have permission to create directories and write the installation logs to the $HOME and /tmp directories on the computer where you are installing products.
  • The account must have ftp and telnet enabled.
  • The account must have access to a root account on the computer where PATROL is installed.

None

Operating systems

You can install PATROL for Application Management on any OS that is supported by the TrueSight Infrastructure Management console or the PATROL Agent 9.6 with which it is installed. These consoles have different requirements, so check the requirements for each if you are installing the KM on more than one console. For details about the requirements and supported platforms for these consoles, see the Product Availability and Compatibility (PAC) page on the BMC Customer Support website at http://www.bmc.com/support/product-availability-compatibility.

None

Language supportTo correctly display an application name that includes non-English letters, the corresponding PATROL Agent must be installed on a system that supports the language localization.None
Was this page helpful? Yes No Submitting... Thank you

Comments