Troubleshooting the Infoblox NIOS adapter

This topic provides information about troubleshooting issues specific to the Infoblox NIOS adapter.


Message: The version of perl module [X.XrX-X-XXXXXX] doesn't match the server version [Y.YrY-Y-YYYYY]. Please upgrade your Infoblox perl module package.

Explanation: This error occurs when the version of the Infoblox Perl module that you installed is not compatible with server version. The Infoblox Perl module version must match the version of the Infoblox application.

User response: Follow the steps in Prerequisites for the Infoblox NIOS adapter to install the compatible version of the Infoblox Perl module.


Message: com.realops.foundation.adapterframework.AdapterException: Message[summary=Message[summary=An error occurred. Response Code:1006 - Response Description:500 Can't verify SSL peers without knowing which Certificate Authorities to trust, detail=An error occurred. Response Code:1006 - Response Description:500 Can't verify SSL peers without knowing which Certificate Authorities to trust], detail=Message[summary=An error occurred. Response Code:1006 - Response Description:500 Can't verify SSL peers without knowing which Certificate Authorities to trust, detail=An error occurred. Response Code:1006 - Response Description:500 Can't verify SSL peers without knowing which Certificate Authorities to trust.]]

Explanation: This error occurs when the environment variable PERL_LWP_SSL_VERIFY_HOSTNAME is set to true or 1, or is missing.

User response: Set the environment variable PERL_LWP_SSL_VERIFY_HOSTNAME to 0 (Windows) or false (Unix).

Was this page helpful? Yes No Submitting... Thank you

Comments